ロリポップでweb.pyが使えなくなった

ロリポップのサーバーを新サーバーに移行したら、Pythonのフレームワーク「web.py」が使えなくなってしまいました。

WEBサーバー移設メンテナンスのお知らせ – 2016年01月15日 12時00分 / メンテナンス情報 / お知らせ – レンタルサーバーならロリポップ!
https://lolipop.jp/info/mainte/5189/

原因はよく分かりませんがmime.typesでPermission deniedとなるようです。

Permission denied: '/etc/mime.types'

ということで、システムを少し変更してみました。

web.pyはPython3で使えないため、システムを移行させる良い機会だったと考えることにしたいと思います。


実は、このエラーには経験があって、xreaのサーバーが更新された際にもweb.pyでエラーになり、web.pyの利用を断念したことがあります。GMO系列のサーバーということで、同じ理由なのかなと想像します。(さくらインターネットでは問題なく使えています。)

コメントを残す

メールアドレスが公開されることはありません。